summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorR. Bernstein <rocky@gnu.org>2010-01-21 03:48:13 -0500
committerR. Bernstein <rocky@gnu.org>2010-01-21 03:48:13 -0500
commite889ba3557c4baa3197c68feedeccc7a9eb0cb07 (patch)
tree73e05d14ae898b61d8a7aa69b221364e0955613e /test/Makefile.am
parent2b4a36f758de3e7d7b728e8af90b215563f3bbf4 (diff)
cygwin fixes.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 9c4831ab..4fbdbf83 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -101,5 +101,11 @@ test: check-am
check-am: make-executable
make-executable: check_nrg.sh check_cue.sh check_paranoia.sh
chmod +x *.sh
- if test ! -f cdda.bin ; then $(LN_S) $(abs_top_srcdir)/test/data/cdda.bin cdda.bin ; fi
- if test ! -f isofs-m1.bin ; then $(LN_S) $(abs_top_srcdir)/test/data/isofs-m1.bin isofs-m1.bin ; fi
+ if test ! -f cdda.bin ; then \
+ test -L cdda.bin && $(RM) cdda.bin ; \
+ $(LN_S) $(abs_top_srcdir)/test/data/cdda.bin cdda.bin ; \
+ fi
+ if test ! -f isofs-m1.bin ; then \
+ test -L cdda.bin && $(RM) isofs-m1.bin ; \
+ $(LN_S) $(abs_top_srcdir)/test/data/isofs-m1.bin isofs-m1.bin ; \
+ fi