summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorrocky <rocky>2004-05-07 10:57:50 +0000
committerrocky <rocky>2004-05-07 10:57:50 +0000
commite286bafd953803983f19a506c3a0d4d8a0fdd05a (patch)
tree832715db87aca3bedf768e90290412218cc3fd88 /test/Makefile.am
parentd31f2f4489abe986a6d1c1d942ee97fce462ecff (diff)
cdrdo TOC parsing regression tests.
testdefault.c: more verbose about what's going on.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 4c7f9763..d64919ac 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,4 +1,4 @@
-# $Id: Makefile.am,v 1.20 2004/05/04 11:47:53 rocky Exp $
+# $Id: Makefile.am,v 1.21 2004/05/07 10:57:50 rocky Exp $
#
# Copyright (C) 2003, 2004 Rocky Bernstein <rocky@panix.com>
#
@@ -23,16 +23,17 @@
#
# There's a problem with doing make distcheck for testdefault.
# A reminder of why I hate automake.
-hack = testassert testischar testiso9660 check_sizeof
+hack = check_sizeof testassert testischar testiso9660 testtoc
noinst_PROGRAMS = $(hack) testdefault
INCLUDES = -I$(top_srcdir) $(LIBCDIO_CFLAGS)
+check_sizeof_LDADD = $(LIBISO9660_LIBS) $(LIBCDIO_LIBS)
testassert_LDADD = $(LIBCDIO_LIBS)
testdefault_LDADD = $(LIBCDIO_LIBS)
testischar_LDADD = $(LIBISO9660_LIBS) $(LIBCDIO_LIBS)
testiso9660_LDADD = $(LIBISO9660_LIBS) $(LIBCDIO_LIBS)
-check_sizeof_LDADD = $(LIBISO9660_LIBS) $(LIBCDIO_LIBS)
+testtoc_LDADD = $(LIBCDIO_LIBS)
check_SCRIPTS = check_nrg.sh check_cue.sh check_cd_read.sh \
check_iso.sh check_opts.sh
@@ -47,6 +48,8 @@ check_DATA = vcd_demo.right \
check_opts3.right check_opts4.right check_opts5.right \
check_opts6.right check_opts7.right \
isofs-m1-read.right cdda-read.right \
+ t1.toc t2.toc t3.toc t4.toc t5.toc t6.toc t7.toc t8.toc t9.toc \
+ bad-mode1.toc bad-msf-1.toc bad-msf-2.toc \
copying.iso copying.right
EXTRA_DIST = $(check_SCRIPTS) $(check_DATA) \