summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorColin Guthrie <colin@mageia.org>2014-10-17 13:51:25 +0200
committerColin Guthrie <colin@mageia.org>2014-11-03 12:32:23 +0000
commitfb1ca6f0c1799259bad85bee8d984d62871584b9 (patch)
tree0e7bb64b198a54f2c26e494f53186013cc59aa5a /src/Makefile.am
parentf7da58b73fd9f324d5a96746a2cdfc05eb37047a (diff)
build-sys: Add support for newer systemd without compatibility libs
In newer versions of systemd some libraries were combined for the sake of general simplicity. This change checks against the newer name first and avoids separate pkgconfig checks if it's found. We probably want to keep support for the older library names for some time. systemd does allow for the shipping of compatibility pkgconfig files to not break downstream code like ourselves which is why this likely hasn't been "fixed" until now. With this change we no longer rely on systemd having been built with those compatibility pkgconfig files.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d2642096..71e20343 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -707,8 +707,8 @@ libpulsecommon_@PA_MAJORMINOR@_la_LDFLAGS += $(X11_LIBS)
endif
if HAVE_SYSTEMD_JOURNAL
-libpulsecommon_@PA_MAJORMINOR@_la_CFLAGS += $(SYSTEMDJOURNAL_FLAGS)
-libpulsecommon_@PA_MAJORMINOR@_la_LDFLAGS += $(SYSTEMDJOURNAL_LIBS)
+libpulsecommon_@PA_MAJORMINOR@_la_CFLAGS += $(SYSTEMD_FLAGS) $(SYSTEMDJOURNAL_FLAGS)
+libpulsecommon_@PA_MAJORMINOR@_la_LDFLAGS += $(SYSTEMD_LIBS) $(SYSTEMDJOURNAL_LIBS)
endif
# proplist-util.h uses these header files, but not the library itself!
@@ -2061,8 +2061,8 @@ module_console_kit_la_CFLAGS = $(AM_CFLAGS) $(DBUS_CFLAGS)
module_systemd_login_la_SOURCES = modules/module-systemd-login.c
module_systemd_login_la_LDFLAGS = $(MODULE_LDFLAGS)
-module_systemd_login_la_LIBADD = $(MODULE_LIBADD) $(SYSTEMDLOGIN_LIBS)
-module_systemd_login_la_CFLAGS = $(AM_CFLAGS) $(SYSTEMDLOGIN_CFLAGS)
+module_systemd_login_la_LIBADD = $(MODULE_LIBADD) $(SYSTEMD_LIBS) $(SYSTEMDLOGIN_LIBS)
+module_systemd_login_la_CFLAGS = $(AM_CFLAGS) $(SYSTEMD_CFLAGS) $(SYSTEMDLOGIN_CFLAGS)
# GConf support
module_gconf_la_SOURCES = modules/gconf/module-gconf.c