summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTanu Kaskinen <tanuk@iki.fi>2016-12-05 22:20:42 +0200
committerTanu Kaskinen <tanuk@iki.fi>2016-12-09 13:09:26 +0200
commitc81f3da53b908a05e6325b6bc0dfb4cd5b08f8ec (patch)
tree8bf9a5a256e16aa5dd7740398c801e70d4958b82 /src/Makefile.am
parent6a786c93758b9cf2128938a8459c3387c0532a1e (diff)
remove module-xenpv-sink
The module doesn't build any more[1], and when starting to investigate the build failure, I asked the module author if he'd know something about the breakage. He said that he didn't know about backward compatibility problems with libxen, but more importantly, he said that the module probably doesn't have any users[2]. It doesn't make sense to keep maintaining a module that doesn't have users, so let's drop it. [1] https://bugs.freedesktop.org/show_bug.cgi?id=98793 [2] https://lists.freedesktop.org/archives/pulseaudio-discuss/2016-November/027172.html
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 0 insertions, 15 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2d5bdd49..f8586b3b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1373,12 +1373,6 @@ modlibexec_LTLIBRARIES += \
module-lirc.la
endif
-if HAVE_XEN
-modlibexec_LTLIBRARIES += \
- module-xenpv-sink.la
-endif
-
-
if HAVE_EVDEV
modlibexec_LTLIBRARIES += \
module-mmkbd-evdev.la
@@ -1503,7 +1497,6 @@ SYMDEF_FILES = \
module-zeroconf-discover-symdef.h \
module-bonjour-publish-symdef.h \
module-lirc-symdef.h \
- module-xenpv-sink-symdef.h \
module-mmkbd-evdev-symdef.h \
module-http-protocol-tcp-symdef.h \
module-http-protocol-unix-symdef.h \
@@ -1922,14 +1915,6 @@ module_lirc_la_LIBADD = $(MODULE_LIBADD) $(LIRC_LIBS)
module_lirc_la_CFLAGS = $(AM_CFLAGS) $(LIRC_CFLAGS)
-# Xen PV driver
-
-module_xenpv_sink_la_SOURCES = modules/xen/module-xenpv-sink.c modules/xen/gntalloc.h modules/xen/gntdev.h
-module_xenpv_sink_la_LDFLAGS = $(MODULE_LDFLAGS)
-module_xenpv_sink_la_LIBADD = $(MODULE_LIBADD) $(XEN_LIBS)
-module_xenpv_sink_la_CFLAGS = $(AM_CFLAGS) $(XEN_CFLAGS) -I$(top_srcdir)/src/modules/xen
-
-
# Linux evdev
module_mmkbd_evdev_la_SOURCES = modules/module-mmkbd-evdev.c