summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMihai Moldovan <ionic@ionic.de>2017-02-25 10:35:06 +0100
committerTanu Kaskinen <tanuk@iki.fi>2017-02-27 16:45:49 +0200
commitb282f3bb9668bc859e880f615c78a1fe305fc035 (patch)
tree07feb3311c487122edcc2af5632e20b328262b8b /src/Makefile.am
parenta8e0556120ed8f6e3263eb2202aae3cb6c1e3975 (diff)
build-sys: FlatCarbon is dead. Good riddance.
FlatCarbon was the flattened Carbon version used in Mac OS Classic (i.e., pre Mac OS X.) It was shipped as legacy software until 10.8, then dropped completely. Using CoreServices is good enough, manually including FlatCarbon headers only lead to build failures for users who had old versions of Xcode lingering around their machines. v2: don't accidentally drop the OS X semaphore implementation.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5b723e65..3ff1139f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -785,8 +785,6 @@ libpulsecommon_@PA_MAJORMINOR@_la_SOURCES += \
pulsecore/mutex-posix.c pulsecore/mutex.h \
pulsecore/thread-posix.c pulsecore/thread.h \
pulsecore/semaphore-osx.c pulsecore/semaphore.h
-libpulsecommon_@PA_MAJORMINOR@_la_CFLAGS += "-I/Developer/Headers/FlatCarbon/"
-#libpulsecommon_@PA_MAJORMINOR@_la_LDFLAGS += "-framework CoreServices"
else !OS_IS_DARWIN
libpulsecommon_@PA_MAJORMINOR@_la_SOURCES += \
pulsecore/mutex-posix.c pulsecore/mutex.h \