summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDavid Henningsson <david.henningsson@canonical.com>2014-11-03 11:01:00 +0100
committerDavid Henningsson <david.henningsson@canonical.com>2014-11-14 11:44:33 +0100
commit1ffede3c855d47a371b2d846f2a496797c46e3af (patch)
treee56832f0c82be6d0d2d96beb7c46e6779a2bc902 /src/Makefile.am
parent807c98a37dcdb65557847cd79e657bfe29c12698 (diff)
bluez 5: Build both headset backends, if available
Enable both ofono and native backends to be built into the same libbluez5-util. Never build the null backend. Signed-off-by: David Henningsson <david.henningsson@canonical.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3cab31f1..4e60a985 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2129,8 +2129,16 @@ module_bluez4_device_la_CFLAGS = $(AM_CFLAGS) $(DBUS_CFLAGS) $(SBC_CFLAGS)
libbluez5_util_la_SOURCES = \
modules/bluetooth/bluez5-util.c \
modules/bluetooth/bluez5-util.h \
- modules/bluetooth/a2dp-codecs.h \
- modules/bluetooth/backend-@BLUETOOTH_HEADSET_BACKEND@.c
+ modules/bluetooth/a2dp-codecs.h
+if HAVE_BLUEZ_5_OFONO_HEADSET
+libbluez5_util_la_SOURCES += \
+ modules/bluetooth/backend-ofono.c
+endif
+if HAVE_BLUEZ_5_NATIVE_HEADSET
+libbluez5_util_la_SOURCES += \
+ modules/bluetooth/backend-native.c
+endif
+
libbluez5_util_la_LDFLAGS = -avoid-version
libbluez5_util_la_LIBADD = $(MODULE_LIBADD) $(DBUS_LIBS)
libbluez5_util_la_CFLAGS = $(AM_CFLAGS) $(DBUS_CFLAGS)