summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index cf1fb89a..c6b095c8 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -199,10 +199,18 @@ all-local: $(BUILT_DOCS) $(HTML_DIR)/*
clean-local:
$(RM) -r $(HTML_DIR) devel-man
[ "x$(builddir)" != "x$(srcdir)" ] && $(RM) $(builddir)/*.sgml || :
+dist-local-check-docs-enabled:
+ @true
else
htmldoc_DATA += $(srcdir)/$(HTML_DIR)/*
all-local:
clean-local:
+dist-local-check-docs-enabled:
+ @echo "*** --enable-man must be used in order to make dist"
+ @false
endif
+# force doc rebulid after configure
+dist-hook-local: dist-local-check-docs-enabled
+
-include $(top_srcdir)/git.mk