summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAkira TAGOH <akira@tagoh.org>2018-05-11 21:39:50 +0900
committerAkira TAGOH <akira@tagoh.org>2018-05-11 21:54:24 +0900
commitf665852df90cd5a28c3040af8f484999ca3dfa4e (patch)
tree9f232ab93e4507cd413325db65ea7d9e175b9c6a /test/Makefile.am
parent307639cff143341cb10273db1a19264ba28b247e (diff)
Add a testrunner for conf
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index e5b8626a..117ba01f 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -59,6 +59,13 @@ check_PROGRAMS += test-name-parse
test_name_parse_LDADD = $(top_builddir)/src/libfontconfig.la
TESTS += test-name-parse
+if ENABLE_JSONC
+check_PROGRAMS += test-conf
+test_conf_CFLAGS = $(JSONC_CFLAGS)
+test_conf_LDADD = $(top_builddir)/src/libfontconfig.la $(JSONC_LIBS)
+TESTS += test-conf.sh
+endif
+
EXTRA_DIST=run-test.sh $(TESTDATA) out.expected-long-family-names out.expected-no-long-family-names
CLEANFILES=out fonts.conf out.expected