summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGlen Low <glen.low@pixelglow.com>2008-05-24 15:59:35 -0700
committerKeith Packard <keithp@keithp.com>2008-05-24 15:59:35 -0700
commitc6228a34b0ebaab3df395163b3b9246da2aa7d8c (patch)
tree2257a6e0058c40a26c5898c8881e7c3956139204 /Makefile.am
parent557f87f7337df1d78c04d2c993916d1d1748360f (diff)
Fix Win32 build error: install tries to run fc-cache locally (bug 15928).
When building in Win32 e.g. with MinGW, the install tries to run fc-cache locally but the required DLL's are not in the path. I've included a patch for this to fix Makefile.in to run fc-cache from bindir but obviously this should be applied to Makefile.am instead. (the second part of this patch was already in the tree)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9cd177da..b9c0321c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -95,8 +95,8 @@ install-data-local:
$(INSTALL_DATA) fonts.conf $(DESTDIR)$(configdir)/fonts.conf; \
fi; fi
@(if $(RUN_FC_CACHE_TEST); then \
- echo " fc-cache/fc-cache -s -f -v"; \
- fc-cache/fc-cache -s -f -v; \
+ echo " $(bindir)/fc-cache/fc-cache -s -f -v"; \
+ $(bindir)/fc-cache/fc-cache -s -f -v; \
else \
echo "***"; \
echo "*** Warning: fonts.cache not built"; \