summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkira TAGOH <akira@tagoh.org>2013-09-30 11:30:00 +0900
committerAkira TAGOH <akira@tagoh.org>2013-09-30 11:30:00 +0900
commit9161ed1e4a3f4afaee6dbcfc0b84a279ad99b397 (patch)
treec67696235f36446b66fe781b3cb199a4cea178e2 /Makefile.am
parent96c5f3cf0ff57e7bbb08cc1e0e78ed0542096484 (diff)
Add the relative path for <include> to fonts.conf if the parent path is same to fonts.conf
Bug 69836 - fonts.conf.in update for Windows cross-compiling
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d310b4b6..2b949e43 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -90,12 +90,14 @@ $(srcdir)/ChangeLog:
.PHONY: ChangeLog
+FC_CONFIGDIR = $(subst $(BASECONFIGDIR)/,,$(CONFIGDIR))
+
fonts.conf: fonts.conf.in Makefile
sed \
-e 's,@FC_CACHEDIR\@,$(FC_CACHEDIR),g' \
-e 's,@FC_DEFAULT_FONTS\@,$(FC_DEFAULT_FONTS),g' \
-e 's,@FC_FONTPATH\@,$(FC_FONTPATH),g' \
- -e 's,@CONFIGDIR\@,$(CONFIGDIR),g' \
+ -e 's,@CONFIGDIR\@,$(FC_CONFIGDIR),g' \
-e 's,@PACKAGE\@,$(PACKAGE),g' \
-e 's,@VERSION\@,$(VERSION),g' \
$(srcdir)/$@.in > $@.tmp && \