summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2013-01-02 18:07:13 -0600
committerBehdad Esfahbod <behdad@behdad.org>2013-01-02 18:23:55 -0600
commit538f1579e86fdcf471cea58945bf8c674d5b91e7 (patch)
tree3df50fc2b90252f42abc296e269b5012e483f83a /Makefile.am
parent46ab96b8fa029fbc8ccf69a6f2fda89866e3ac9c (diff)
Trying to fix distcheck
Doesn't work though :(. Building docs is very fragile... At least, if docbook is present, distcheck passes now.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index cbc3df07..6aee88a5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,10 +21,15 @@
# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
# PERFORMANCE OF THIS SOFTWARE.
-DOCSRC=@DOCSRC@
SUBDIRS=fontconfig fc-case fc-lang fc-glyphname src \
fc-cache fc-cat fc-list fc-match fc-pattern fc-query fc-scan \
- conf.d $(DOCSRC) test
+ conf.d test
+if ENABLE_DOCS
+SUBDIRS += doc
+DIST_SUBDIRS = $(SUBDIRS)
+else
+DIST_SUBDIRS = $(SUBDIRS) doc
+endif
AUTOMAKE_OPTIONS = dist-bzip2
ACLOCAL_AMFLAGS = -I m4
@@ -149,4 +154,6 @@ debuild-dirs: distdir
cp -a $(distdir) $(distdir).orig
$(RM) -r $(distdir).orig/debian
+DISTCHECK_CONFIGURE_FLAGS =
+
-include $(top_srcdir)/git.mk