summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2005-02-28 18:56:15 +0000
committerKeith Packard <keithp@keithp.com>2005-02-28 18:56:15 +0000
commit414f720281b416736b92913f4bcbceac1a781cde (patch)
tree3548cf9f2dd3dac29a747d040be6a25fc41327ab /Makefile.am
parent47b49bf14b5cd433366a02374dfaf1c27a57cc91 (diff)
Create prototype /etc/fonts/conf.d directory with a few sample
configuration files. Deprecate use of local.conf for local customizations in favor of this directory based scheme which is more easily integrated into installation systems. Tag FC_EMBOLDEN as a boolean variable
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 2 insertions, 22 deletions
diff --git a/Makefile.am b/Makefile.am
index 16d2f218..44a506d5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,13 +22,13 @@
# PERFORMANCE OF THIS SOFTWARE.
DOCSRC=@DOCSRC@
-SUBDIRS=fontconfig fc-case fc-lang fc-glyphname src fc-cache fc-list fc-match $(DOCSRC) test
+SUBDIRS=fontconfig fc-case fc-lang fc-glyphname src \
+ fc-cache fc-list fc-match conf.d $(DOCSRC) test
EXTRA_DIST = \
fontconfig.pc.in \
fonts.conf.in \
fonts.dtd \
- local.conf \
fontconfig.spec.in \
fontconfig.spec \
fontconfig-zip.in
@@ -58,15 +58,6 @@ install-data-local:
echo " $(INSTALL_DATA) fonts.conf $(DESTDIR)$(configdir)/fonts.conf"; \
$(INSTALL_DATA) fonts.conf $(DESTDIR)$(configdir)/fonts.conf; \
fi; fi
- if [ -f $(DESTDIR)$(configdir)/local.conf ]; then \
- echo "not overwriting existing $(DESTDIR)$(configdir)/local.conf"; \
- else if [ -f $(srcdir)/local.conf ]; then \
- echo " $(INSTALL_DATA) $(srcdir)/local.conf $(DESTDIR)$(configdir)/local.conf"; \
- $(INSTALL_DATA) $(srcdir)/local.conf $(DESTDIR)$(configdir)/local.conf; \
- else if [ -f local.conf ]; then \
- echo " $(INSTALL_DATA) local.conf $(DESTDIR)$(configdir)/local.conf"; \
- $(INSTALL_DATA) local.conf $(DESTDIR)$(configdir)/local.conf; \
- fi; fi; fi
if $(RUN_FC_CACHE_TEST); then \
echo " fc-cache/fc-cache -f -v"; \
fc-cache/fc-cache -f -v; \
@@ -90,14 +81,3 @@ uninstall-local:
rm -f $(DESTDIR)$(configdir)/fonts.conf; \
fi; \
fi; fi
- if [ -f $(srcdir)/local.conf ]; then \
- if cmp -s $(srcdir)/local.conf $(DESTDIR)$(configdir)/local.conf; then \
- echo " uninstall standard $(DESTDIR)$(configdir)/local.conf"; \
- rm -f $(DESTDIR)$(configdir)/local.conf; \
- fi; \
- else if [ -f local.conf ]; then \
- if cmp -s local.conf $(DESTDIR)$(configdir)/local.conf; then \
- echo " uninstall standard $(DESTDIR)$(configdir)/local.conf"; \
- rm -f $(DESTDIR)$(configdir)/local.conf; \
- fi; \
- fi; fi