summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@koto.keithp.com>2007-10-18 03:52:29 -0700
committerKeith Packard <keithp@koto.keithp.com>2007-10-18 03:52:29 -0700
commit00268a50e8b99e80ff25ee2a77a925398f89693f (patch)
tree5c267140f82b0dd419ad02d5fd70fdf8e80d9ec7 /Makefile.am
parent3ae9258f9e825ed576dc315ec79009188bb422e2 (diff)
Fix ChangeLog generation to avoid circular make dependency
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 88e55af9..e0539023 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,12 +66,9 @@ MAINTAINERCLEANFILES += ChangeLog
EXTRA_DIST += ChangeLog
-ChangeLog: $(srcdir)/ChangeLog
-
-$(srcdir)/ChangeLog:
- @if test -d "$(srcdir)/.git"; then \
- (cd "$(srcdir)" && \
- ./missing --run git-log --stat) | fmt --split-only > $@.tmp \
+ChangeLog:
+ if test -d "$(srcdir)/.git"; then \
+ (GIT_DIR=$(top_srcdir)/.git ./missing --run git-log --stat) | fmt --split-only > $@.tmp \
&& mv -f $@.tmp $@ \
|| ($(RM) $@.tmp; \
echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
@@ -82,7 +79,7 @@ $(srcdir)/ChangeLog:
echo A git checkout and git-log is required to generate this file >> $@); \
fi
-.PHONY: ChangeLog $(srcdir)/ChangeLog
+.PHONY: ChangeLog
install-data-local:
$(mkinstalldirs) $(DESTDIR)$(configdir) $(DESTDIR)$(fc_cachedir)