summaryrefslogtreecommitdiff
path: root/glamor/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2014-04-01 21:15:43 -0700
committerKeith Packard <keithp@keithp.com>2014-04-03 13:07:51 -0700
commitd78c257f523908760c1b872cc4bef3d42eb31f50 (patch)
treef59ef06cdb58fb21871e8b9b94e3cc5fc2a5fb47 /glamor/Makefile.am
parent693e6bea897e4c9473a9f22dd8b90df3437e04a1 (diff)
glamor: Add simple upload/download functions in glamor_transfer
These use glTexSubimage2D for upload and glReadPixels for download. There are a variety of interfaces to the basic function as needed by the callers. Signed-off-by: Keith Packard <keithp@keithp.com> Signed-off-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'glamor/Makefile.am')
-rw-r--r--glamor/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/glamor/Makefile.am b/glamor/Makefile.am
index 8555e4087..3664fd380 100644
--- a/glamor/Makefile.am
+++ b/glamor/Makefile.am
@@ -24,6 +24,8 @@ libglamor_la_SOURCES = \
glamor_render.c \
glamor_gradient.c \
glamor_program.c \
+ glamor_transfer.c \
+ glamor_transfer.h \
glamor_transform.c \
glamor_trapezoid.c \
glamor_tile.c \