summaryrefslogtreecommitdiff
path: root/gst-libs/gst/vaapi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/gst/vaapi/Makefile.am')
-rw-r--r--gst-libs/gst/vaapi/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/gst-libs/gst/vaapi/Makefile.am b/gst-libs/gst/vaapi/Makefile.am
index d4e3397b..394e52a7 100644
--- a/gst-libs/gst/vaapi/Makefile.am
+++ b/gst-libs/gst/vaapi/Makefile.am
@@ -168,6 +168,11 @@ libgstvaapi_source_priv_h += \
$(NULL)
libgstvaapi_cflags += $(GST_CODEC_PARSERS_CFLAGS)
libgstvaapi_libs += $(GST_CODEC_PARSERS_LIBS)
+
+if USE_JPEG_DECODER
+libgstvaapi_source_c += gstvaapidecoder_jpeg.c
+libgstvaapi_source_h += gstvaapidecoder_jpeg.h
+endif
endif
if USE_LOCAL_CODEC_PARSERS