summaryrefslogtreecommitdiff
path: root/gst/audioresample/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2005-08-23 19:29:38 +0000
committerDavid Schleef <ds@schleef.org>2005-08-23 19:29:38 +0000
commitae8f41b6586f1d35fcbaa9ff38d313c5bd7eedba (patch)
tree9ac6d04c261538e25f78542bc0626665ec704893 /gst/audioresample/Makefile.am
parent84d0eb4f88846bc0d94ba2263c6fca085013272c (diff)
gst/audioresample/Makefile.am: Leet audioresampling code
Original commit message from CVS: * gst/audioresample/Makefile.am: Leet audioresampling code * gst/audioresample/buffer.c: * gst/audioresample/buffer.h: * gst/audioresample/debug.c: * gst/audioresample/debug.h: * gst/audioresample/functable.c: * gst/audioresample/functable.h: * gst/audioresample/gstaudioresample.c: * gst/audioresample/gstaudioresample.h: * gst/audioresample/resample.c: * gst/audioresample/resample.h: * gst/audioresample/resample_chunk.c: * gst/audioresample/resample_functable.c: * gst/audioresample/resample_ref.c:
Diffstat (limited to 'gst/audioresample/Makefile.am')
-rw-r--r--gst/audioresample/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/gst/audioresample/Makefile.am b/gst/audioresample/Makefile.am
new file mode 100644
index 000000000..bff050347
--- /dev/null
+++ b/gst/audioresample/Makefile.am
@@ -0,0 +1,21 @@
+
+plugin_LTLIBRARIES = libgstaudioresample.la
+
+resample_SOURCES = \
+ functable.c \
+ functable.h \
+ resample.c \
+ resample_functable.c \
+ resample_ref.c \
+ resample_chunk.c \
+ resample.h \
+ debug.c \
+ debug.h \
+ buffer.c \
+ buffer.h
+
+libgstaudioresample_la_SOURCES = gstaudioresample.c $(resample_SOURCES)
+libgstaudioresample_la_CFLAGS = $(GST_CFLAGS) $(LIBOIL_CFLAGS)
+libgstaudioresample_la_LIBADD = $(LIBOIL_LIBS)
+libgstaudioresample_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+