summaryrefslogtreecommitdiff
path: root/giscanner/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'giscanner/Makefile.am')
-rw-r--r--giscanner/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/giscanner/Makefile.am b/giscanner/Makefile.am
index a2044cf..05724dc 100644
--- a/giscanner/Makefile.am
+++ b/giscanner/Makefile.am
@@ -56,6 +56,15 @@ pkgpyexec_PYTHON = \
utils.py \
xmlwriter.py
+# Make sure all python files are available in builddir, so the module can be
+# invoked by other tools during build time
+all-local:
+ for file in $(pkgpyexec_PYTHON); do \
+ if [ ! -f $$file ]; then \
+ $(LN_S) $(srcdir)/$$file $$file; \
+ fi \
+ done
+
_giscanner_la_CFLAGS = \
$(PYTHON_INCLUDES) \
$(GOBJECT_CFLAGS) \