summaryrefslogtreecommitdiff
path: root/gthread/Makefile.am
diff options
context:
space:
mode:
authorSebastian Wilhelmi <wilhelmi@ira.uka.de>1999-03-18 14:41:38 +0000
committerSebastian Wilhelmi <wilhelmi@src.gnome.org>1999-03-18 14:41:38 +0000
commit3e956742324ba6bef056524fa93362f85c932cdd (patch)
treea7d8523c2383aee2277d7fcfc979fc1563dbe869 /gthread/Makefile.am
parent05f42cc0e2e639effb95206d20d39070de3be0c7 (diff)
added new AC_SUBST(GTHREAD_COMPILE_IMPL_DEFINES) to hold various defines
1999-03-18 Sebastian Wilhelmi <wilhelmi@ira.uka.de> * configure.in: added new AC_SUBST(GTHREAD_COMPILE_IMPL_DEFINES) to hold various defines to get the right thread implementation on different platforms. Also look in -ldce for pthread_create. Should make it work on HP-UX 10.x. * gthread/Makefile.am (INCLUDES): Added @GTHREAD_COMPILE_IMPL_DEFINES@.
Diffstat (limited to 'gthread/Makefile.am')
-rw-r--r--gthread/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gthread/Makefile.am b/gthread/Makefile.am
index 21b860773..275245536 100644
--- a/gthread/Makefile.am
+++ b/gthread/Makefile.am
@@ -1,6 +1,7 @@
## Process this file with automake to produce Makefile.in
-INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/gthread -DG_LOG_DOMAIN=\"GThread\"
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/gthread \
+ -DG_LOG_DOMAIN=\"GThread\" @GTHREAD_COMPILE_IMPL_DEFINES@
EXTRA_DIST = \
gthread-posix.c \