summaryrefslogtreecommitdiff
path: root/tests/old/testsuite/plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/old/testsuite/plugin/Makefile.am')
-rw-r--r--tests/old/testsuite/plugin/Makefile.am16
1 files changed, 3 insertions, 13 deletions
diff --git a/tests/old/testsuite/plugin/Makefile.am b/tests/old/testsuite/plugin/Makefile.am
index 4ef486d3a..a8d1887bb 100644
--- a/tests/old/testsuite/plugin/Makefile.am
+++ b/tests/old/testsuite/plugin/Makefile.am
@@ -1,13 +1,10 @@
-TESTS_ENVIRONMENT = GST_PLUGIN_PATH=$(top_builddir) GST_REGISTRY=$(top_builddir)/testsuite/test-registry.xml
+include ../Rules
-plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
plugin_LTLIBRARIES = libtestplugin.la libtestplugin2.la
-# FIXME : tests need fixing
-testprogs = static dynamic linked loading registry static2
+tests_pass = static dynamic static2 linked loading registry
+tests_fail =
-AM_CFLAGS = $(GST_CFLAGS)
-LIBS = $(GST_LIBS)
libtestplugin_la_SOURCES = testplugin.c
libtestplugin_la_CFLAGS = $(GST_CFLAGS)
@@ -20,10 +17,3 @@ linked_LIBS = libtestplugin.la libtestplugin2.la
static_SOURCES = static.c testplugin_s.c testplugin2_s.c
-check_PROGRAMS = $(testprogs)
-
-TESTS = $(top_builddir)/tools/gst-register $(testprogs)
-
-# override to _not_ install the test plugins
-install-pluginLTLIBRARIES:
-