summaryrefslogtreecommitdiff
path: root/gst-libs/gst/uridownloader/Makefile.am
diff options
context:
space:
mode:
authorThiago Santos <thiago.sousa.santos@collabora.com>2013-04-16 19:47:02 -0300
committerThiago Santos <thiago.sousa.santos@collabora.com>2013-05-07 20:02:41 -0300
commit859635ca0102bc286d1d8633d2688efb9bb4fae9 (patch)
treed80f0d06499ad506d7de320568582768b0942d0b /gst-libs/gst/uridownloader/Makefile.am
parent4d4fd09a3a00ce97dcaacb30377e350391fd64b0 (diff)
uridownloader: refactor gsturidownloader to its own lib
gsturidownloader can be reused by other plugins, better have it into its own lib
Diffstat (limited to 'gst-libs/gst/uridownloader/Makefile.am')
-rw-r--r--gst-libs/gst/uridownloader/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/gst-libs/gst/uridownloader/Makefile.am b/gst-libs/gst/uridownloader/Makefile.am
new file mode 100644
index 000000000..a63f2ac69
--- /dev/null
+++ b/gst-libs/gst/uridownloader/Makefile.am
@@ -0,0 +1,40 @@
+lib_LTLIBRARIES = libgsturidownloader-@GST_API_VERSION@.la
+
+libgsturidownloader_@GST_API_VERSION@_la_SOURCES = \
+ gstfragment.c gsturidownloader.c
+
+libgsturidownloader_@GST_API_VERSION@includedir = \
+ $(includedir)/gstreamer-@GST_API_VERSION@/gst/uridownloader
+
+libgsturidownloader_@GST_API_VERSION@include_HEADERS = \
+ gstfragment.h gsturidownloader.h gsturidownloader_debug.h
+
+libgsturidownloader_@GST_API_VERSION@_la_CFLAGS = \
+ $(GST_PLUGINS_BAD_CFLAGS) \
+ -DGST_USE_UNSTABLE_API \
+ $(GST_CFLAGS)
+
+libgsturidownloader_@GST_API_VERSION@_la_LIBADD = \
+ $(GST_BASE_LIBS) \
+ $(GST_LIBS)
+
+libgsturidownloader_@GST_API_VERSION@_la_LDFLAGS = \
+ $(GST_LIB_LDFLAGS) \
+ $(GST_ALL_LDFLAGS) \
+ $(GST_LT_LDFLAGS)
+
+Android.mk: $(BUILT_SOURCES) Makefile.am
+ androgenizer -:PROJECT libgsturidownloader -:STATIC libgsturidownloader-@GST_API_VERSION@ \
+ -:TAGS eng debug \
+ -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
+ -:SOURCES $(libgsturidownloader_@GST_API_VERSION@_la_SOURCES) \
+ $(built_sources) \
+ -:CFLAGS $(DEFS) $(libgsturidownloader_@GST_API_VERSION@_la_CFLAGS) \
+ -:LDFLAGS $(libgsturidownloader_@GST_API_VERSION@_la_LDFLAGS) \
+ $(libgsturidownloader@GST_API_VERSION@_la_LIBADD) \
+ -ldl \
+ -:HEADER_TARGET gstreamer-@GST_API_VERSION@/gst/uridownloader \
+ -:HEADERS $(libgsturidownloaderinclude_HEADERS) \
+ $(built_headers) \
+ -:PASSTHROUGH LOCAL_ARM_MODE:=arm \
+ > $@