summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAaron Bockover <abockover@novell.com>2010-07-09 18:55:45 -0400
committerAaron Bockover <abockover@novell.com>2010-07-09 19:00:46 -0400
commitcf900630d55402aedf2745ac0ed9bc8fe8eaa006 (patch)
tree28118d5b201a15b97b37dd54540b2610175cedc8 /configure.ac
parentcac26f61b70d6283d11882b9318812d79eef22c4 (diff)
Add Banshee.WebBrowser and Banshee.AmazonMp3.Store
This is a big commit that introduces two to-die-for features into Banshee. First is a generic GTK WebKit-based embedded browser, called OssiferWebView, which extends WebKitWebView. OssiferWebView is written in C, because it makes fairly heavy use of WebKit and Soup APIs, for which the C# bindings are rather lacking. A simple, easy-to-bind API is exposed. In C#, Banshee.WebBrowser.OssiferWebView is available for extensions to use for embedding a reliable web browser. GTK WebKit 1.2.0+ is required. Fortunately, this is very easy to build on openSUSE 11.2-era systems. What is most important though, is the introduction of the Banshee.AmazonMp3.Store extension, which leverages Banshee.WebBrowser.OssiferWebView to provide an integrated and dedicated Amazon MP3 store browser. Music can be browsed, searched, and purchased in Banshee just as you would through Amazon MP3's web site in your regular browser, however there are two (current) user experience improvements: 1. A cookie is always set by Banshee that tells the Amazon MP3 web site that a valid Amazon MP3 downloader is installed, thus avoiding nagging messages about downloading the installer (which notoriously does not work on Linux systems); and 2. Mime-type hooks ensure that when audio/x-amzxml content is delivered by Amazon, that it is downloaded and immediately imported by the Banshee.AmazonMp3.AmazonMp3DownloaderService. The result being that as soon as a purchase is made, the purchase begins downloading and importing into your Banshee library automatically. Further browser improvements and polish will be on the way: 1. Basic back/forward navigation 2. Searching from within the regular Banshee UI 3. Ability to log out from within the regular Banshee UI 4. Lots of other stuff I haven't thought of I'm not as think as you drunk I am, Ossifer!
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 12 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 6622b66e8..47cab46fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,6 +117,7 @@ SHAMROCK_CHECK_MONODOC
dnl webkit (optional through --disable-webkit)
BANSHEE_CHECK_WEBKIT
+BANSHEE_CHECK_LIBWEBKIT
dnl gdata (optional through --disable-youtube)
BANSHEE_CHECK_YOUTUBE
@@ -295,6 +296,8 @@ src/Core/Banshee.Core/Makefile
src/Core/Banshee.Services/Makefile
src/Core/Banshee.ThickClient/Makefile
src/Core/Banshee.Widgets/Makefile
+src/Core/Banshee.WebBrowser/Makefile
+src/Core/Banshee.WebBrowser/libossifer/Makefile
src/Backends/Makefile
src/Backends/Banshee.Gio/Makefile
@@ -325,6 +328,7 @@ src/Dap/Banshee.Dap.Karma/Makefile
src/Extensions/Makefile
src/Extensions/Banshee.AmazonMp3/Makefile
+src/Extensions/Banshee.AmazonMp3.Store/Makefile
src/Extensions/Banshee.Audiobook/Makefile
src/Extensions/Banshee.AudioCd/Makefile
src/Extensions/Banshee.BooScript/Makefile
@@ -386,15 +390,18 @@ ${PACKAGE}-${VERSION}
Karma: ${enable_karmasharp}
Extra Features:
+ Web Browser: ${have_libwebkit} (webkit-1.0 >= 1.2.0, libsoup-2.4 >= 2.26)
+ + GNOME Proxy ${have_libsoup_gnome} (libsoup-gnome-2.4 >= 2.26)
+ + Amazon MP3 ${have_libwebkit}
+ + Wikipedia ${have_libwebkit}
Boo Scripting: ${enable_boo}
Builtin Equalizer: ${enable_builtin_equalizer}
DAAP: ${enable_daap}
- GIO Backend: ${enable_gio} (requires glib >= 2.22, gtk-sharp-beans, and gio-sharp)
- Library Watcher: ${HAVE_MONO_2_4_3} (requires Mono >= 2.4.3)
+ GIO Backend: ${enable_gio} (glib >= 2.22, gtk-sharp-beans, and gio-sharp)
+ Library Watcher: ${HAVE_MONO_2_4_3} (Mono >= 2.4.3)
Podcasts: ${enable_podcast}
- Wikipedia: ${enable_webkit} (requires webkit-sharp)
- Gapless playback: ${ENABLE_GAPLESS} (requires gstreamer-plugins-base > 0.10.25.2)
- YouTube extension: ${enable_youtube} (requires gdata-sharp >= 1.4)
+ Gapless playback: ${ENABLE_GAPLESS} (gstreamer-plugins-base > 0.10.25.2)
+ YouTube extension: ${enable_youtube} (gdata-sharp >= 1.4)
Build/Development:
Unit Tests: ${do_tests} (requires nunit >= ${NUNIT_REQUIRED})