summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3eb6fd5..d35231c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -144,7 +144,7 @@ libwayland_cursor_la_CFLAGS = \
-DICONDIR=\"$(ICONDIR)\"
-TESTS = \
+built_test_programs = \
array-test \
client-test \
display-test \
@@ -165,11 +165,13 @@ TESTS = \
protocol-logger-test
if ENABLE_CPP_TEST
-TESTS += cpp-compile-test
+built_test_programs += cpp-compile-test
endif
+TESTS = $(built_test_programs)
+
check_PROGRAMS = \
- $(TESTS) \
+ $(built_test_programs) \
exec-fd-leak-checker
noinst_PROGRAMS = \