summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSiarhei Siamashka <siarhei.siamashka@nokia.com>2010-05-12 01:34:57 +0300
committerSiarhei Siamashka <siarhei.siamashka@nokia.com>2010-05-13 21:04:55 +0300
commitcfc4e38852dc244198a9bfcab07d9014bba21d53 (patch)
tree36387a99735e7f180abe5bde1bc8ece5599b2838 /configure.ac
parentf905ebb03d8ed8a3ceb76c84a10735aa209168d3 (diff)
test: added OpenMP support for better utilization of multiple CPU cores
Some of the tests are quite heavy CPU users and may benefit from using multiple CPU cores, so the programs from 'test' directory are now built with OpenMP support. OpenMP is easy to use, portable and also takes care of making a decision about how many threads to spawn.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c9d0c662..56a6e4dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,6 +77,10 @@ AC_CHECK_FUNCS([getisax])
AC_C_BIGENDIAN
AC_C_INLINE
+# Check for OpenMP support (only supported by autoconf >=2.62)
+OPENMP_CFLAGS=
+m4_ifdef([AC_OPENMP], [AC_OPENMP], [AC_SUBST(OPENMP_CFLAGS)])
+
AC_CHECK_SIZEOF(long)
# Checks for Sun Studio compilers