summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBlaž Tomažič <blaz.tomazic@gmail.com>2012-08-29 22:39:35 +0200
committerBlaž Tomažič <blaz.tomazic@gmail.com>2012-09-05 14:56:00 +0200
commit9a6044d069f3c96b61eabf59b58ada52391fbb46 (patch)
tree4991fb6f438d04bf010c92ee83b79f1d4ffd44aa /tests/CMakeLists.txt
parent13d744e7c3cf04f41529675e09761c845deba85d (diff)
cmake: Build OpenCL tests
Build OpenCL tests to binaries with 'cl-' prefix. Each test type adds another prefix to it, for example Custom test has a 'cl-custom-' prefix. Signed-off-by: Blaž Tomažič <blaz.tomazic@gmail.com>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 05824b473..64f38c54c 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -25,6 +25,10 @@ IF(OPENGL_egl_LIBRARY)
add_subdirectory (egl)
ENDIF(OPENGL_egl_LIBRARY)
+IF(BUILD_CL_TESTS)
+ add_subdirectory (cl)
+ENDIF(BUILD_CL_TESTS)
+
IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
add_subdirectory (mesa)
ENDIF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")