summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDylan Noblesmith <nobled@dreamwidth.org>2012-02-27 20:01:23 +0000
committerDylan Noblesmith <nobled@dreamwidth.org>2012-03-03 13:16:44 +0000
commit2cb512bd5dd2bb789d6a805aa800b4c92fae26ff (patch)
tree34d9aac999d92427b5d9cc76ecfa33f4a4938849 /tests/CMakeLists.txt
parente627eb887b14de448349a89e67ceba813904df74 (diff)
don't write generated header to the source directory
It was impossible to have the source directory read-only. Also add the include_directories() directive for tests/util in just one place, under tests/, so that all subdirectories inherit it. A bunch of CMakeLists.txt files duplicate it, so delete those redundant include flags: sed -i -e "/^\t\${piglit_SOURCE_DIR}\/tests\/util/ d" \ `grep piglit_SOURCE_DIR -rl tests/ | grep "CMakeLists\.gl"`
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 52d16d4a9..1a53693b4 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,3 +1,8 @@
+include_directories(
+ ${piglit_BINARY_DIR}/tests/util
+ ${piglit_SOURCE_DIR}/tests/util
+)
+
add_subdirectory (util)
add_subdirectory (bugs)
add_subdirectory (fbo)