summaryrefslogtreecommitdiff
path: root/hw/kdrive/fbdev/Makefile.am
diff options
context:
space:
mode:
authorDodji Seketeli <dodji@openedhand.com>2007-09-05 17:46:49 +0200
committerDodji Seketeli <dodji@openedhand.com>2007-09-05 17:46:49 +0200
commit6c89d1237c4fdce961b30a8eaee964af5d56565e (patch)
treec3a4e3f507c2f9cb4c5e0b734ae6e37b8d52ff94 /hw/kdrive/fbdev/Makefile.am
parent28e48cd8e6e4c412a49d7177daad6d3c93c28e08 (diff)
Kdrive: unbreak kdrive linking
* configure.ac: re-sort Kdrive libs so that symbols get properly resolved. Basically, all some libs are present in both $KDRIVE_LIBS and $XSERVER_LIBS, and some libs orders are not correct. So I made sure Kdrive servers don't have to link against $KDRIVE_LIBS *and* $XSERVER_LIBS. They just have to link against $KDRIVE_LIBS now. * hw/kdrive/*/Makefile.am: update those makefile to reflect the change in configure.ac
Diffstat (limited to 'hw/kdrive/fbdev/Makefile.am')
-rw-r--r--hw/kdrive/fbdev/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/hw/kdrive/fbdev/Makefile.am b/hw/kdrive/fbdev/Makefile.am
index ea2aff3b3..1ce4833a7 100644
--- a/hw/kdrive/fbdev/Makefile.am
+++ b/hw/kdrive/fbdev/Makefile.am
@@ -16,8 +16,7 @@ Xfbdev_SOURCES = \
Xfbdev_LDADD = \
libfbdev.a \
- @KDRIVE_LIBS@ \
- @XSERVER_LIBS@
+ @KDRIVE_LIBS@
Xfbdev_DEPENDENCIES = \
libfbdev.a \