summaryrefslogtreecommitdiff
path: root/dix/Makefile.am
diff options
context:
space:
mode:
authorDrew Parsons <dparsons@debian.org>2008-03-10 22:54:49 +1100
committerDrew Parsons <dparsons@debian.org>2008-04-18 01:20:36 +1000
commit966ae1781f3ca563e15a9a1b8cab6fab94e07fe9 (patch)
tree8481549e2490ad3fcd12893f90affd69db2df1ba /dix/Makefile.am
parent571206832d454771e3c638c7515767958365c19c (diff)
Create dix/libXpdix.la for Xprint-specific build of libdix.la
(cherry picked from commit 4e2c6dbabdbbaaca213fd08edd422de15d0900cc) required because of commit 7c0709a736c0f3aa011de67dd2c2962585ab146e, which made requestingClient in dix specific to Xprint only. Add to XPRINT_LIBS in hw/xprint/Makefile.am in front of $(XSERVER_LIBS) to override definitions in libdix.la for standard xservers. Follows 571206832d454771e3c638c7515767958365c19c (providing -DXPRINT to xprint subdirs). Note it may be possible to restructure the code so that requestingClient is stored elsewhere than in dix. See discussions following http://lists.freedesktop.org/archives/xorg/2008-March/033844.html If this is done it may be possible to revert this commit (if not 571206...).
Diffstat (limited to 'dix/Makefile.am')
-rw-r--r--dix/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/dix/Makefile.am b/dix/Makefile.am
index b7b1ec071..e44b51081 100644
--- a/dix/Makefile.am
+++ b/dix/Makefile.am
@@ -1,4 +1,10 @@
-noinst_LTLIBRARIES = libdix.la libxpstubs.la
+standard_dix_libs = libdix.la libxpstubs.la
+
+if XPRINT
+noinst_LTLIBRARIES = $(standard_dix_libs) libXpdix.la
+else
+noinst_LTLIBRARIES = $(standard_dix_libs)
+endif
AM_CFLAGS = $(DIX_CFLAGS) \
-DVENDOR_NAME=\""@VENDOR_NAME@"\" \
@@ -39,7 +45,11 @@ libdix_la_SOURCES = \
libxpstubs_la_SOURCES = \
xpstubs.c
-INCLUDES = -I$(top_srcdir)/Xprint
+if XPRINT
+libXpdix_la_SOURCES = $(libdix_la_SOURCES)
+libXpdix_la_CPPFLAGS = -I$(top_srcdir)/hw/xprint
+libXpdix_la_CFLAGS = $(AM_CFLAGS) $(XPRINT_CFLAGS)
+endif
EXTRA_DIST = buildatoms BuiltInAtoms CHANGES Xserver.d Xserver-dtrace.h.in