summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorCarl Worth <cworth@cworth.org>2009-10-15 14:58:39 -0700
committerCarl Worth <cworth@cworth.org>2009-10-15 14:58:39 -0700
commitcdad5e10768978b11088f82858a1e6e0037dc0a7 (patch)
treeb7665859e0d3bb31c8c5195e44335afcfddf5974 /test/Makefile.am
parentb0f309abb33fb7e068199c941835af0217d8d1fc (diff)
Mark in-fill-empty-trapezoid as an XFAIL test.
Otherwise, it was disrupting my attempts to release a snapshot, (since it doesn't respect CAIRO_TEST_TARGET=" " and not run like most of the tests do).
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index ac9d62ff..8c36e659 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1086,6 +1086,10 @@ $(REFERENCE_IMAGES)
# room, with Carl as a moderator and not let them out
# until they have come up with an interface and
# semantics that actually work. :-)
+# in-fill-empty-trapezoid The cairo_in_fill () function can sometimes
+# produce false positives when the tessellator
+# produces empty trapezoids and the query
+# point lands exactly on a trapezoid edge.
# long-lines - range overflow of fixed-point
# scale-offset-image - loss of precision converting a cairo matrix to
# scale-offset-similar pixman's fixed point format.
@@ -1109,6 +1113,7 @@ degenerate-path$(EXEEXT) \
device-offset-scale$(EXEEXT) \
extend-pad$(EXEEXT) \
fallback-resolution$(EXEEXT) \
+in-fill-empty-trapezoid$(EXEEXT) \
long-lines$(EXEEXT) \
self-copy-overlap$(EXEEXT) \
self-intersecting$(EXEEXT) \