summaryrefslogtreecommitdiff
path: root/perf/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2007-04-19 21:41:43 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2007-04-19 21:42:13 +0100
commit2c79f8b75bd5bb0bb3bf054fb2b3cae6de382a7c (patch)
treeeb6bd4663606761fb64641a927c3865f14452c5a /perf/Makefile.am
parent3631c11eb4ab49f2bb3b9ef0478e5516793f221f (diff)
Fix command line for running cairo-perf under valgrind.
The CAIRO_PERF_ENVIRONMENT slipped into the middle of the command line instead of at the start.
Diffstat (limited to 'perf/Makefile.am')
-rw-r--r--perf/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/perf/Makefile.am b/perf/Makefile.am
index 8e7d5136..16f48e2c 100644
--- a/perf/Makefile.am
+++ b/perf/Makefile.am
@@ -85,13 +85,13 @@ CLEANFILES = \
index.html
perf-valgrind: cairo-perf FORCE
- $(top_srcdir)/libtool --mode=execute \
+ $(CAIRO_PERF_ENVIRONMENT) $(top_srcdir)/libtool --mode=execute \
valgrind $(VALGRIND_MEMCHECK_FLAGS) $(EXTRA_VALGRIND_FLAGS) \
- $(CAIRO_PERF_ENVIRONMENT) ./cairo-perf 2>&1 | tee valgrind-log
+ ./cairo-perf 2>&1 | tee valgrind-log
perf-callgrind: cairo-perf FORCE
- $(top_srcdir)/libtool --mode=execute \
+ $(CAIRO_PERF_ENVIRONMENT) $(top_srcdir)/libtool --mode=execute \
valgrind $(VALGRIND_CALLGRIND_FLAGS) $(EXTRA_VALGRIND_FLAGS) \
- $(CAIRO_PERF_ENVIRONMENT) ./cairo-perf
+ ./cairo-perf
FORCE: