summaryrefslogtreecommitdiff
path: root/perf/Makefile.am
diff options
context:
space:
mode:
authorCarl Worth <cworth@cworth.org>2006-11-17 17:50:14 -0800
committerCarl Worth <cworth@cworth.org>2006-11-17 18:00:36 -0800
commit1ed3811338a03068b7ce60f83fdd23fe01fec972 (patch)
tree403ba48960a9392165a91993ec919d79b7810f3f /perf/Makefile.am
parenta8faa0aef11abbd743ac9dc0b3127f9384325ee2 (diff)
perf: Add box_outline test case.
This test shows that drawing a 100x100 single-pixel wide box outline is currently 5 to 16 times slower when using the natural cairo_stroke() as compared to a rather awkward cairo_fill() of two rectangles. [ # ] backend-content test-size min(ticks) min(ms) median(ms) stddev. iterations [ 0] image-rgba box-outline-stroke-100 301321 0.218 0.219 0.39% 5 [ 1] image-rgba box-outline-fill-100 18178 0.013 0.013 0.43% 5 [ 0] xlib-rgba box-outline-stroke-100 379177 0.275 0.276 1.39% 6 [ 1] xlib-rgba box-outline-fill-100 83355 0.060 0.060 0.17% 5
Diffstat (limited to 'perf/Makefile.am')
-rw-r--r--perf/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/perf/Makefile.am b/perf/Makefile.am
index 4fa086b9..27316ec2 100644
--- a/perf/Makefile.am
+++ b/perf/Makefile.am
@@ -18,6 +18,7 @@ cairo_perf_SOURCES = \
cairo-perf-cover.c \
cairo-stats.c \
cairo-stats.h \
+ box-outline.c \
fill.c \
paint.c \
stroke.c \