summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2005-01-11 10:03:01 +0000
committerKeith Packard <keithp@keithp.com>2005-01-11 10:03:01 +0000
commitad2225c6f4f18570cbd5e4391788458533895bb8 (patch)
tree764a8f3958ec7efdbc91e40c7aaea9cf92aeec0f /configure.in
parentdc0d812f6c78bfc3e4cbf717cf09a4524d8f149c (diff)
Fix math library detection to use autotools helper
Remove cache memory usage assertions as single objects can be larger than the cache size Decompose font matrix transformations into a couple of helper routines. Return all metrics in font space. Eliminate compiler warning Expect glyph metrics to be in font space. Compute text extents by fetching one glyph metric at a time, transforming to user space and computing the overall bounding box. use 'sincos' where available. Scale factors now ensure the non-scale transform is area preserving. Scale factors requires another parameter to mark the fixed axis. Change license to LGPL Mark int32x32_64_mul as broken (which it still is) Ensure each glyph is located as close to the specified position as possible interface change to _cairo_matrix_compute_scale_factors
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6cc0c7a4..33ce007d 100644
--- a/configure.in
+++ b/configure.in
@@ -34,6 +34,12 @@ AC_PROG_CPP
AM_PROG_LIBTOOL
AC_STDC_HEADERS
+AC_CHECK_LIBM
+
+LIBS="$LIBS $LIBM"
+
+AC_CHECK_FUNCS(sincos)
+
dnl ===========================================================================
AC_ARG_ENABLE(xlib,
@@ -268,7 +274,7 @@ if test "x$GCC" = "xyes"; then
fi
CAIRO_CFLAGS="$CAIRO_CFLAGS $WARN_CFLAGS"
-CAIRO_LIBS="$CAIRO_LIBS -lm"
+CAIRO_LIBS="$CAIRO_LIBS"
AC_SUBST(CAIRO_CFLAGS)
AC_SUBST(CAIRO_LIBS)