summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2005-06-25 23:24:19 +0000
committerKeith Packard <keithp@keithp.com>2005-06-25 23:24:19 +0000
commit3b0c3d0ee84f991347df12249f944c780dde99f8 (patch)
tree08a88cdad152506f1bd1b91145de533ae467d4cb /configure.in
parent574f7f560bf2cc851ad4f3267840e37fa06611fa (diff)
Provide locking macros, implement with pthreads.
Add _cairo_cache_shrink_to which reduces cache memory usage to a specified level. Change global glyph and xlib glyphset caches behaviour to only shrink cache on unlock. This is done by telling the cache code to never shrink (max_memory == 0), and then manually shrinking using _cairo_cache_shrink_to from the unlock function. Fix Carl's variable renaming mixing (cache = cache). reviewed by: cworth
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 413391c2..8fca1e40 100644
--- a/configure.in
+++ b/configure.in
@@ -307,6 +307,14 @@ AC_SUBST(FT_FONT_FEATURE)
dnl ===========================================================================
+#
+# The FreeType backend uses pthread locking when avaialble
+#
+
+AC_CHECK_HEADERS([pthread.h])
+
+dnl ===========================================================================
+
AC_ARG_ENABLE(pdf,
[ --disable-pdf Disable cairo's PDF backend],
[use_pdf=$enableval], [use_pdf=yes])