summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2010-08-08 14:45:24 +0200
committerBenjamin Otte <otte@redhat.com>2010-08-08 16:09:13 +0200
commite31b56e020df806aa6180cd2efa0a34e55e5adaf (patch)
tree523c3a7d2763763d082923e5b025297c0c03f275 /configure.ac
parentae2b7b13cd5fdeaee44496056bb99f497346e262 (diff)
configure: Fix gobject handling
1) Explicitly depend on glib, too. 2) Don't link gobject into libcairo proper (thanks Joonas for noticing).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 631c1bd5..94a866e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -655,8 +655,8 @@ dnl ===========================================================================
dnl Build gobject integration library
CAIRO_ENABLE_FUNCTIONS(gobject, gobject, auto, [
- gobject_REQUIRES="gobject-2.0"
- PKG_CHECK_MODULES(gobject, $gobject_REQUIRES, , [AC_MSG_RESULT(no)
+ gobject_REQUIRES="gobject-2.0 glib-2.0"
+ PKG_CHECK_MODULES(GOBJECT, $gobject_REQUIRES, , [AC_MSG_RESULT(no)
use_gobject="no (requires $gobject_REQUIRES http://download.gnome.org/pub/GNOME/sources/glib/)"])
])