summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrea Canciani <ranma42@gmail.com>2011-06-14 10:45:18 +0200
committerAndrea Canciani <ranma42@gmail.com>2011-06-14 15:25:08 +0200
commit45665c0d48396af7bd653d546115a5f36cfa9ae1 (patch)
tree51384068ea22a4dea12635ceaf2969a92100e5f9 /configure.ac
parent9d256b7db90ba0517a2d06a7c99f8e59021c1d6a (diff)
Remove if's from Makefile.sources
make on win32 complains that: make[1]: Entering directory `/home/ranma42/Code/fdo/cairo/src' ../src/Makefile.sources:220: *** missing separator. Stop. Makefile.sources should not contain if's, which are aoutomake-only conditionals. The correct way to conditionally include files is to enable/disable them using C preprocessor macros.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 72caa0dc..5d72c24f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,12 +114,12 @@ CAIRO_ENABLE_FUNCTIONS(xlib_xcb, Xlib/XCB, no, [
if test "x$use_xcb" = "xyes" -a "x$use_xlib" = "xyes"; then
xlib_xcb_REQUIRES="x11-xcb"
PKG_CHECK_MODULES(xlib_xcb, $xlib_xcb_REQUIRES, ,
- [use_xlib_xcb="no (requires $xlib_xcb_REQUIRES http://xcb.freedesktop.org)"])
+ [AC_MSG_RESULT(no)
+ use_xlib_xcb="no (requires $xlib_xcb_REQUIRES http://xcb.freedesktop.org)"])
else
use_xlib_xcb="no (requires both --enable-xlib and --enable-xcb)"
fi
])
-AM_CONDITIONAL(BUILD_XLIB_XCB, test "x$use_xlib_xcb" = "xyes")
CAIRO_ENABLE_FUNCTIONS(xcb_shm, XCB/SHM, auto, [
if test "x$use_xcb" = "xyes"; then
@@ -131,7 +131,6 @@ CAIRO_ENABLE_FUNCTIONS(xcb_shm, XCB/SHM, auto, [
use_xcb_shm="no (requires --enable-xcb)"
fi
])
-AM_CONDITIONAL(BUILD_XCB_SHM, test "x$use_xcb_shm" = "xyes")
dnl ===========================================================================