summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2009-05-09 20:12:29 -0700
committerDan Nicholson <dbn.lists@gmail.com>2009-05-09 21:01:51 -0700
commit2f1fd817abb24a8a4ac6d4fa9f4cd88040ce09f7 (patch)
treec8942774579d3cae8302396a49dbdf6f1cefda2c /configure.ac
parent57e591c23b389d9fb79b89ed44a88aa2b4c1f7a8 (diff)
xts5: Generate tetexec.cfg from configure
Move the tetexec.cfg template to a .in file so we can keep it pristine for the repo.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2162bbe7..903abc0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,7 +54,7 @@ if test "x$BDFTOPCF" = x || test "x$MKFONTDIR" = x; then
AC_MSG_ERROR([bdftopcf and mkfontdir are required to build the test fonts])
fi
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
src/Makefile
src/tet3/Makefile
@@ -80,3 +80,9 @@ xts5/fonts/Makefile
xts5/tset/Makefile
xts5/tset/Xproto/Makefile
])
+
+AC_CONFIG_COMMANDS([tetexec.cfg],
+ [TET_ROOT=`pwd` perl -p $srcdir/xts5/bin/xts-config \
+ < $srcdir/xts5/tetexec.cfg.in > xts5/tetexec.cfg])
+
+AC_OUTPUT