summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2009-05-10 12:26:07 -0700
committerDan Nicholson <dbn.lists@gmail.com>2009-05-10 12:26:07 -0700
commit1839a7bd978a92dc8f751c1949296d5df1acaded (patch)
treefd49dfa1471d3524a459bb11930a3f24fca99c5f /configure.ac
parentcd862f4c59925b118601c61bc2021bd00f9c900f (diff)
xts5: Check for xset and xdpyinfo before running xts-config
Ensure that the user has xset and xdpyinfo and that xts-config uses those tools. Additionally, move the generation of tetexec.cfg to the Makefile to handle all the environment variables and prerequisites.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 4 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 00467b3c..7e185074 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,8 +57,10 @@ fi
dnl Needed for generating tetexec.cfg with xts-config
AC_PATH_PROG([PERL], [perl])
-if test "x$PERL" = x; then
- AC_MSG_ERROR([perl is required to run xts-config])
+AC_PATH_PROG([XSET], [xset])
+AC_PATH_PROG([XDPYINFO], [xdpyinfo])
+if test "x$PERL" = x || test "x$XSET" = x || test "x$XDPYINFO" = x; then
+ AC_MSG_ERROR([perl, xset and xdpyinfo are required to run xts-config])
fi
dnl See what display the user wants to use for testing
@@ -101,9 +103,4 @@ xts5/tset/Makefile
xts5/tset/Xproto/Makefile
])
-AC_CONFIG_COMMANDS([tetexec.cfg],
- [TET_ROOT=`pwd` DISPLAY=$XT_DISPLAY $PERL -p $srcdir/xts5/bin/xts-config \
- < $srcdir/xts5/tetexec.cfg.in > xts5/tetexec.cfg],
- [PERL="$PERL"; XT_DISPLAY="$XT_DISPLAY"])
-
AC_OUTPUT