summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJon TURNEY <jon.turney@dronecode.org.uk>2017-05-08 11:40:22 +0100
committerAdam Jackson <ajax@redhat.com>2017-05-10 14:43:52 -0400
commite67ca940473e249c7b9712ce6d515310ed1e4cf9 (patch)
treed2ad12c7d36185a999d986e404ff2215e916d5b8 /meson.build
parent16054647abfc9fe5f71d0098e17415e45fa28199 (diff)
meson: An empty array is not a dependency object
Using the meson idiom of initializing a variaible to an empty array to represent a null value does not work well for a variable expected to hold a dependency object, as trying to apply found() to it will fail (currently). I think this can be demonstrated by configuing with Dglamor=no, then gbm_dep is set to [] in meson.build, and then tested with found() in include/meson.build. Use dependency('') to create an empty dependency. Future work: In the autotools build GBM is required if build_xorg & build_glamor. I suspect that it was also required for build_xwayland & build_glamor, but that was never checked. That test seems to have gone missing in meson.build, the required:false when checking for gbm should possibly be dropped? Signed-off-by: Jon Turney <jon.turney@dronecode.org.uk> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 0a14de4dd..dab3d4423 100644
--- a/meson.build
+++ b/meson.build
@@ -177,7 +177,7 @@ endif
build_dbus = build_hal or build_systemd_logind
-udev_dep = []
+udev_dep = dependency('', required:false)
if build_udev
udev_dep = dependency('libudev', version: '>= 143')
endif
@@ -198,7 +198,7 @@ else
build_glamor = get_option('glamor') == 'yes'
endif
-gbm_dep = []
+gbm_dep = dependency('', required:false)
if build_glamor
gbm_dep = dependency('gbm', version: '>= 10.2', required: false)
if gbm_dep.found()