summaryrefslogtreecommitdiff
path: root/hw/xfree86/Makefile.am
diff options
context:
space:
mode:
authorAdam Jackson <ajax@nwnk.net>2006-05-09 18:04:29 +0000
committerAdam Jackson <ajax@nwnk.net>2006-05-09 18:04:29 +0000
commit86ffb46358965509aa3ee536f15cb5a4e5e04426 (patch)
tree899e93de29f4e34dff19b0f2eae0d1c87e0bcde5 /hw/xfree86/Makefile.am
parentb46d6a44fa97a3e66de828385026b7f84d9e59b8 (diff)
Bug #5209: Re-enable building APM and ACPI support. (Michel Dänzer)
Diffstat (limited to 'hw/xfree86/Makefile.am')
-rw-r--r--hw/xfree86/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/hw/xfree86/Makefile.am b/hw/xfree86/Makefile.am
index 1bec7193e..8665926f6 100644
--- a/hw/xfree86/Makefile.am
+++ b/hw/xfree86/Makefile.am
@@ -21,20 +21,24 @@ INCLUDES = @XORG_INCS@
Xorg_SOURCES = xorg.c
-DISTCLEANFILES = xorg.c
-
-xorg.c:
+# libxorgos and libcommon need symbols from each other
+noinst_LTLIBRARIES = libosandcommon.la
+libosandcommon_la_SOURCES = osandcommon.c
+libosandcommon_la_LIBADD = \
+ os-support/libxorgos.la \
+ common/libcommon.la
+
+osandcommon.c xorg.c:
touch $@
-OS_LIBS = os-support/libxorgos.la
+DISTCLEANFILES = osandcommon.c xorg.c
XORG_LIBS = \
@XORG_CORE_LIBS@ \
common/libinit.a \
loader/libloader.a \
- common/libcommon.a \
+ libosandcommon.la \
parser/libxf86config.a \
- $(OS_LIBS) \
dummylib/libdummy.a \
dixmods/libdixmods.la \
@XORG_LIBS@