summaryrefslogtreecommitdiff
path: root/hw/xfree86/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-09-20 15:50:31 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-09-20 15:50:31 +0000
commit7d0f47c43c5c177cae0f375ceaeef892e4c9663a (patch)
tree6baa52360d20dfd81a6341910a7131b2e88f0c47 /hw/xfree86/Makefile.am
parentb623c60745ca486667657fa39ad517d1f7a72794 (diff)
Add --disable-install-setuid option so you can build as non-root and
chown/chmod later. Also disable by default on platforms that don't need setuid root X servers (Darwin & SPARC's, according to InstallXserverSetUID settings in the old Imake config files).
Diffstat (limited to 'hw/xfree86/Makefile.am')
-rw-r--r--hw/xfree86/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/hw/xfree86/Makefile.am b/hw/xfree86/Makefile.am
index 5de87c9e6..413a1f615 100644
--- a/hw/xfree86/Makefile.am
+++ b/hw/xfree86/Makefile.am
@@ -67,6 +67,10 @@ endif
install-data-local:
$(mkdir_p) $(logdir)
+
install-exec-local:
+if INSTALL_SETUID
chown root $(DESTDIR)$(bindir)/Xorg
chmod u+s $(DESTDIR)$(bindir)/Xorg
+endif
+