summaryrefslogtreecommitdiff
path: root/glamor/Makefile.am
diff options
context:
space:
mode:
authorDave Airlie <airlied@redhat.com>2012-12-29 06:28:17 +0000
committerEric Anholt <eric@anholt.net>2013-12-18 11:23:53 -0800
commitefbdc9e90f36494b07508aeaba40c9eb01eab398 (patch)
treeef065833987e36ec874057bebfb0b75284cd665a /glamor/Makefile.am
parent80f5e21daeed79654d6e1976f2766eb528f01d47 (diff)
glamor: fix make distcheck part 1
This just adds the headers, then it falls over on the sdk_HEADERS as it overrides proper install paths by the looks of it. Signed-off-by: Dave Airlie <airlied@redhat.com>
Diffstat (limited to 'glamor/Makefile.am')
-rw-r--r--glamor/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/glamor/Makefile.am b/glamor/Makefile.am
index 766aac776..e1ee86d90 100644
--- a/glamor/Makefile.am
+++ b/glamor/Makefile.am
@@ -20,10 +20,13 @@ AM_CFLAGS = $(CWARNFLAGS) $(XORG_CFLAGS) $(DIX_CFLAGS) $(LIBDRM_CFLAGS)
libglamor_la_LDFLAGS = -avoid-version
libglamor_la_SOURCES = \
+ compat-api.h \
glamor.c \
glamor_copyarea.c \
glamor_copywindow.c \
glamor_core.c \
+ glamor_debug.h \
+ glamor_gl_dispatch.h \
glamor_fill.c \
glamor_fillspans.c \
glamor_getspans.c \
@@ -42,6 +45,7 @@ libglamor_la_SOURCES = \
glamor_copyplane.c\
glamor_glyphblt.c\
glamor_polyops.c\
+ glamor_priv.h\
glamor_pixmap.c\
glamor_largepixmap.c\
glamor_picture.c\
@@ -49,7 +53,9 @@ libglamor_la_SOURCES = \
glamor_gl_dispatch.c\
glamor_fbo.c\
glamor_compositerects.c\
- glamor.h
+ glamor_utils.h\
+ glamor.h\
+ glapi.h
sdk_HEADERS = glamor.h