summaryrefslogtreecommitdiff
path: root/glamor/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2013-12-18 15:27:52 -0800
committerEric Anholt <eric@anholt.net>2014-02-14 18:30:01 -0800
commit4afe15d8bfd575c010ed1868697a7922a37ab378 (patch)
tree5b3b4a274ce3e36ef104f782039bebc04a8b752c /glamor/Makefile.am
parent781c692cf970642865f0e537f4905c43192f9935 (diff)
glamor: Put in a pluggable context switcher for GLX versus EGL.
The GLX side just gets the context from the current state. That's also something I want to do for EGL, so that the making a context is separate from initializing glamor, but I think I need the modesetting driver in the server before I think about hacking on that more. The previous code was rather incestuous, along with pulling in xf86 dependencies to our dix code. The new code just initializes itself from the current state. Signed-off-by: Eric Anholt <eric@anholt.net> Reviewed-by: Keith Packard <keithp@keithp.com>
Diffstat (limited to 'glamor/Makefile.am')
-rw-r--r--glamor/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/glamor/Makefile.am b/glamor/Makefile.am
index 17cae97f5..12a57c441 100644
--- a/glamor/Makefile.am
+++ b/glamor/Makefile.am
@@ -6,6 +6,7 @@ AM_CFLAGS = $(CWARNFLAGS) $(DIX_CFLAGS) $(GLAMOR_CFLAGS)
libglamor_la_SOURCES = \
glamor.c \
+ glamor_context.h \
glamor_copyarea.c \
glamor_copywindow.c \
glamor_core.c \
@@ -13,6 +14,7 @@ libglamor_la_SOURCES = \
glamor_fill.c \
glamor_fillspans.c \
glamor_getspans.c \
+ glamor_glx.c \
glamor_glyphs.c \
glamor_polyfillrect.c \
glamor_polylines.c \