summaryrefslogtreecommitdiff
path: root/hw/xnest/Makefile.am
diff options
context:
space:
mode:
authorYaakov Selkowitz <yselkowitz@users.sourceforge.net>2010-03-17 13:52:38 -0500
committerYaakov Selkowitz <yselkowitz@users.sourceforge.net>2010-03-22 00:45:51 -0500
commitfa7e062962d17862032bc600bfcffd486addb063 (patch)
tree5e1cc705426fc03c940a3c1172b7cf55da424395 /hw/xnest/Makefile.am
parent037869d7b876f43158df88d63788b93a5d6187c1 (diff)
Use EXEEXT in relink rules for portable DDXs
On Cygwin and MinGW, executables use the .exe suffix. Autoconf and automake set EXEEXT on these platforms, and leave it empty on others where no suffix is used. $(EXEEXT) must be appended to executable names in custom rules for portability: http://www.gnu.org/software/automake/manual/html_node/EXEEXT.html Signed-off-by: Yaakov Selkowitz <yselkowitz@users.sourceforge.net> Reviewed-by: Alan Coopersmith <alan.coopersmith@sun.com> Reviewed-by: Julien Cristau <jcristau@debian.org>
Diffstat (limited to 'hw/xnest/Makefile.am')
-rw-r--r--hw/xnest/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/hw/xnest/Makefile.am b/hw/xnest/Makefile.am
index f95aab140..3e9749083 100644
--- a/hw/xnest/Makefile.am
+++ b/hw/xnest/Makefile.am
@@ -89,4 +89,4 @@ SUFFIXES += .$(APP_MAN_SUFFIX) .man
$(LN_S) $< $@
relink:
- rm -f Xnest && $(MAKE) Xnest
+ rm -f Xnest$(EXEEXT) && $(MAKE) Xnest$(EXEEXT)