summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-11-20 23:01:02 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-11-20 23:01:02 +0000
commita1f110bda80bb3b8e4f602385ca5ccd96cf3f786 (patch)
tree34649a63ea18a7414281e84a3a2fe0511fbc6939 /configure.ac
parent385730d23944c24dd9af45b27f62c1161abc48b2 (diff)
Make sure XKM_OUTPUT_DIR (used in code) ends in / (so paths don't get hosed
when appending file names) but XKB_COMPILED_DIR (used in Makefiles) does not so install-sh -d doesn't get confused when the directory already exists.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 692f30754..7531ed390 100644
--- a/configure.ac
+++ b/configure.ac
@@ -353,7 +353,7 @@ AC_ARG_WITH(xkb-path, AS_HELP_STRING([--with-xkb-path=PATH], [Path to XK
[ XKBPATH="${datadir}/X11/xkb" ])
AC_ARG_WITH(xkb-output, AS_HELP_STRING([--with-xkb-output=PATH], [Path to XKB output dir (default: ${datadir}/X11/xkb/compiled)]),
[ XKBOUTPUT="$withval" ],
- [ XKBOUTPUT="compiled/" ])
+ [ XKBOUTPUT="compiled" ])
AC_ARG_WITH(rgb-path, AS_HELP_STRING([--with-rgb-path=PATH], [Path to RGB database (default: ${datadir}/X11/rgb)]),
[ RGBPATH="$withval" ],
[ RGBPATH="${datadir}/X11/rgb" ])
@@ -1156,9 +1156,15 @@ if [[ x$XKBOUTPUT_FIRSTCHAR != x/ ]] ; then
XKBOUTPUT="$XKB_BASE_DIRECTORY/$XKBOUTPUT"
fi
+# XKM_OUTPUT_DIR (used in code) must end in / or file names get hosed
+# XKB_COMPILED_DIR (used in Makefiles) must not or install-sh gets confused
+
+XKBOUTPUT=`echo $XKBOUTPUT/ | sed 's|/*$|/|'`
+XKB_COMPILED_DIR=`echo $XKBOUTPUT | sed 's|/*$||'`
+
AC_DEFINE_DIR(XKM_OUTPUT_DIR, XKBOUTPUT, [Path to XKB output dir])
-AC_SUBST(XKM_OUTPUT_DIR)
+AC_SUBST(XKB_COMPILED_DIR)
dnl and the rest of these are generic, so they're in config.h
AC_DEFINE(XFreeXDGA, 1, [Build XDGA support])