summaryrefslogtreecommitdiff
path: root/Xext/Makefile.am
diff options
context:
space:
mode:
authorYaakov Selkowitz <yselkowitz@users.sourceforge.net>2010-03-22 00:44:28 -0500
committerYaakov Selkowitz <yselkowitz@users.sourceforge.net>2010-03-22 00:48:04 -0500
commitabf4e0b7e349b0238b2b97a16b8a308b5026af31 (patch)
tree2002b6dc3c8174acf5f10684d8e825e9b08d5706 /Xext/Makefile.am
parent57a049ea89b008c0b60316c3b6e6ff5c8fbd4cad (diff)
New header for XF86Bigfont server functions
Xext/xf86bigfont.c contains three non-static functions which are called elsewhere in the server. This creates a new header containing these declarations in order to fix several warnings: xf86bigfont.c:285: warning: no previous prototype for `XF86BigfontFreeFontShm' dixfonts.c:502: warning: implicit declaration of function `XF86BigfontFreeFontS$ dixfonts.c:502: warning: nested extern declaration of `XF86BigfontFreeFontShm' log.c:436: warning: implicit declaration of function `XF86BigfontCleanup' log.c:436: warning: nested extern declaration of `XF86BigfontCleanup' Signed-off-by: Yaakov Selkowitz <yselkowitz@users.sourceforge.net> Reviewed-by: Julien Cristau <jcristau@debian.org>
Diffstat (limited to 'Xext/Makefile.am')
-rw-r--r--Xext/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Xext/Makefile.am b/Xext/Makefile.am
index 193d6e5cb..53cbc1fbd 100644
--- a/Xext/Makefile.am
+++ b/Xext/Makefile.am
@@ -107,7 +107,7 @@ MODULE_SRCS += $(MULTIBUFFER_SRCS)
endif
# XF86 Big Font extension
-BIGFONT_SRCS = xf86bigfont.c
+BIGFONT_SRCS = xf86bigfont.c xf86bigfontsrv.h
if XF86BIGFONT
BUILTIN_SRCS += $(BIGFONT_SRCS)
endif