summaryrefslogtreecommitdiff
path: root/Xext/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter@cs.unisa.edu.au>2007-04-30 12:57:42 +0930
committerPeter Hutterer <peter@cs.unisa.edu.au>2007-04-30 12:57:42 +0930
commit5e439109292e54b5c4d1a7bc7b6ac0e42ee285f7 (patch)
tree14e3ee811b3145b29bec73aca64e3060a731e9dd /Xext/Makefile.am
parentf28eea0647f007c2e2415ecc6fceef46201faad4 (diff)
Add GenericEvent extension to Xext.
This adds (unconditional) support for the GE extension. Anything from now on that sends events in MPX will have to use the GE extension. No GE, no MPX events. GE is not actually used yet from anywhere with this commit. You will need to update x11proto, xextproto, libX11, libXext and xcb to the matching xge branches. Things will _NOT_ work without the updated protocol headers and libraries.
Diffstat (limited to 'Xext/Makefile.am')
-rw-r--r--Xext/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Xext/Makefile.am b/Xext/Makefile.am
index 6ea3d7445..29a01ee99 100644
--- a/Xext/Makefile.am
+++ b/Xext/Makefile.am
@@ -23,7 +23,8 @@ BUILTIN_SRCS = \
shape.c \
sleepuntil.c \
sleepuntil.h \
- xtest.c
+ xtest.c \
+ geext.c
# Sources always included in libXextmodule.la & libXext.la
MODULE_SRCS = \
@@ -178,5 +179,6 @@ EXTRA_DIST = \
$(EXTRA_MULTIBUFFER_SRCS) \
$(FONTCACHE_SRCS) \
$(BIGFONT_SRCS) \
- $(DPMS_SRCS)
+ $(DPMS_SRCS) \
+ $(GE_SRCS)