summaryrefslogtreecommitdiff
path: root/test/xi2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/xi2/Makefile.am')
-rw-r--r--test/xi2/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/xi2/Makefile.am b/test/xi2/Makefile.am
index b8362ca8b..ef6d0f0ab 100644
--- a/test/xi2/Makefile.am
+++ b/test/xi2/Makefile.am
@@ -17,6 +17,10 @@ INCLUDES = @XORG_INCS@
TEST_LDADD=../libxservertest.la $(XORG_SYS_LIBS) $(XSERVER_SYS_LIBS) $(GLIB_LIBS)
COMMON_SOURCES=protocol-common.h protocol-common.c
+if XSERVER_DTRACE
+TEST_LDADD += $(OS_LIB) $(DIX_LIB)
+endif
+
protocol_xiqueryversion_LDADD=$(TEST_LDADD)
protocol_xiquerydevice_LDADD=$(TEST_LDADD)
protocol_xiselectevents_LDADD=$(TEST_LDADD)