summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 4 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 2fe685b..fc5943b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,6 +81,7 @@ PKG_CHECK_MODULES([GLIB2], [glib-2.0 >= 2.28])
PKG_CHECK_MODULES(X, [xfixes xrandr >= 1.3 xinerama x11])
PKG_CHECK_MODULES(SPICE, [spice-protocol >= 0.12.8])
PKG_CHECK_MODULES(ALSA, [alsa >= 1.0.22])
+PKG_CHECK_MODULES([DBUS], [dbus-1])
if test "$with_session_info" = "auto" || test "$with_session_info" = "systemd"; then
PKG_CHECK_MODULES([LIBSYSTEMD_LOGIN],
@@ -107,19 +108,9 @@ fi
AM_CONDITIONAL(HAVE_LIBSYSTEMD_LOGIN, test x"$have_libsystemd_login" = "xyes")
if test "$with_session_info" = "auto" || test "$with_session_info" = "console-kit"; then
- PKG_CHECK_MODULES([DBUS],
- [dbus-1],
- [have_console_kit="yes"],
- [have_console_kit="no"])
- if test x"$have_console_kit" = "xno" && test "$with_session_info" = "console-kit"; then
- AC_MSG_ERROR([console-kit support explicitly requested, but some required packages are not available])
- fi
- if test x"$have_console_kit" = "xyes"; then
- AC_DEFINE([HAVE_CONSOLE_KIT], [1], [If defined, vdagentd will be compiled with ConsoleKit support])
- with_session_info="console-kit"
- else
- with_session_info="none"
- fi
+ AC_DEFINE([HAVE_CONSOLE_KIT], [1], [If defined, vdagentd will be compiled with ConsoleKit support])
+ have_console_kit="yes"
+ with_session_info="console-kit"
else
have_console_kit="no"
fi