summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPavel Šimerda <psimerda@redhat.com>2013-07-30 23:09:52 +0200
committerPavel Šimerda <psimerda@redhat.com>2015-01-05 18:39:46 +0100
commit0de60b300ed6cc0fc94c742396112b1274989371 (patch)
treedf7d7f4c06ccb698f481246ff6389c5f01bc6b8b /src/Makefile.am
parenteb2eda4408667395ffb73ec94fc5a02f311b66f5 (diff)
session: merge nm-session-monitor-* modules
Merged all session tracking modules into one source file and simplified it substantially. Now systemd-logind and ConsoleKit support can be built in at the same time and both are detected at runtime. This is useful on source based as well as binary distributions. Original patch written by Fabio Erculiani <lxnay@sabayon.org>, modified by Pavel Šimerda <psimerda@redhat.com> and Thomas Haller <thaller@redhat.com>. https://bugzilla.gnome.org/show_bug.cgi?id=686997 Acked-By: Thomas Haller <thaller@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 0 insertions, 13 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 387d1caa7..e9cedd9d6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -333,15 +333,6 @@ nm_sources = \
NetworkManagerUtils.c \
NetworkManagerUtils.h
-if SESSION_TRACKING_SYSTEMD
-nm_sources += nm-session-monitor-systemd.c
-else
-if SESSION_TRACKING_CK
-nm_sources += nm-session-monitor-ck.c
-else
-nm_sources += nm-session-monitor-null.c
-endif
-endif
if SUSPEND_RESUME_SYSTEMD
nm_sources += nm-sleep-monitor-systemd.c
@@ -432,10 +423,6 @@ AM_CPPFLAGS += \
\
$(NULL)
-if SESSION_TRACKING_CK
-AM_CPPFLAGS += -DCKDB_PATH=\"${CKDB_PATH}\"
-endif
-
libNetworkManager_la_SOURCES = \
$(nm_sources) \
$(glue_sources)