summaryrefslogtreecommitdiff
path: root/libnm-core/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-12-24 14:52:02 +0100
committerThomas Haller <thaller@redhat.com>2018-01-02 10:44:15 +0100
commitad12837bafd1a3c9cca84012dff899a306b651b1 (patch)
tree28dd2f6f27fd20df7d53b0b98340d41b74fdcd26 /libnm-core/meson.build
parent03ba0f1b3af902341ad1ea3b25adafc274109e31 (diff)
build: Workaround for gtkdoc dependencies
gtkdoc uses some custom generated targets as content files. However, there are still two problem. The first is that gtkdoc does not support targets which are not strings. This is being fixed in the following issue: https://github.com/mesonbuild/meson/pull/2806 The second issue is that the gtkdoc function produces a target which is triggered at install time. This makes the dependencies generation to not be triggered. This patch uses a workaround for that second issue. https://mail.gnome.org/archives/networkmanager-list/2017-December/msg00079.html
Diffstat (limited to 'libnm-core/meson.build')
-rw-r--r--libnm-core/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/libnm-core/meson.build b/libnm-core/meson.build
index 1afd45ab0..97040709f 100644
--- a/libnm-core/meson.build
+++ b/libnm-core/meson.build
@@ -177,7 +177,10 @@ foreach docbook: docbooks
input: docbook[1],
output: output,
capture: true,
- command: [perl, enums_to_docbook, docbook[0], docbook[2], '@INPUT@']
+ command: [perl, enums_to_docbook, docbook[0], docbook[2], '@INPUT@'],
+ # FIXME: gtkdoc does not depend directly on this.
+ # https://github.com/mesonbuild/meson/pull/2806
+ build_by_default: true
)
content_files += xml.full_path()