summaryrefslogtreecommitdiff
path: root/hw/kdrive/smi/Makefile.am
diff options
context:
space:
mode:
authorGeorge Sapountzis <gsap7@yahoo.gr>2008-04-18 17:45:53 +0300
committerGeorge Sapountzis <gsap7@yahoo.gr>2008-04-23 18:11:55 +0300
commitefb723e166e5fa89e90c7b400fb4c7979b1f50c0 (patch)
treef95f98c9118a30ff6f5ed94b637148ea9ddb3fb7 /hw/kdrive/smi/Makefile.am
parentfbad87f2ae9f97fcb43546b0fa35f1100415dfec (diff)
glcore: prepare for dynamic loading
glcore gets linked with -ldl, -lpthread for s3tc and glapi xserver needs DLOPEN_LIBS - to dlopen the glcore dso LD_EXPORT_SYMBOLS_FLAG - to export symbols for glcore to use the ld flag is added to kdrive only when GLX is enabled, the net overhead for Xephyr is ~155KB, could be reduced with --dynamic-list.
Diffstat (limited to 'hw/kdrive/smi/Makefile.am')
-rw-r--r--hw/kdrive/smi/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/hw/kdrive/smi/Makefile.am b/hw/kdrive/smi/Makefile.am
index a4d6624c5..bd7077c56 100644
--- a/hw/kdrive/smi/Makefile.am
+++ b/hw/kdrive/smi/Makefile.am
@@ -25,6 +25,10 @@ SMI_LIBS = \
$(top_builddir)/hw/kdrive/vesa/libvesa.a \
@KDRIVE_LIBS@
+if GLX
+Xsmi_LDFLAGS = $(LD_EXPORT_SYMBOLS_FLAG)
+endif
+
Xsmi_LDADD = \
$(SMI_LIBS) \
@KDRIVE_LIBS@